venerdì , giugno 22 2018
Ultime Notizie
Home / Wireless & Networking / Mikrotik / Mikrotik: bloccare accesso Social Network, Sky etc.

Mikrotik: bloccare accesso Social Network, Sky etc.

Ciao Ragazzi,

prima di Natale vi lascio con un nuovo script molto carino, progettato per i device Mikrotik.

In questo esempio vi faccio vedere come bloccare, creando una address list, un servizio (es. Facebook, Sky, Twitter, Porno etc.)

Questo è molto utile perchè i proxy ormai si aggirano facilmente utilizzando https (non tutti occhio!), ma con i device Mikrotik ed il loro firewall integrato, si può fare molto.

Come al solito l’idea viene dal mio amico Frank, poi io la metto in pratica!!! 🙂

Vi spiego cosa fa lo script, che nel mio esempio servirà a bloccare il social network Facebook

Per prima cosa controlla nella cache del DNS se trova una parola contenente la stringa “facebook” e se la trova prende l’indirizzo IP, crea una address list e lo aggiunge al suo interno…Con i prossimi cicli aggiungerà anche le altre occorrenze trovate.

Fatto questo basta semplicemente creare la regola firewall droppando l’intera access list.

Ecco la regola:

/ip firewall filter
add action=drop chain=forward comment=BlockFacebookAddressList dst-address-list=facebook_dns_ips

Mentre di seguito trovate lo script:

:log warning "Script Started ... Adding Facebook DNS ip's to address list name facebook_dns_ips"
:foreach i in=[/ip dns cache find] do={
:local bNew true;
:local cacheName [/ip dns cache all get $i name] ;
:if ([:find [/ip dns cache all get $i name] "facebook"] > 1) do={
:local tmpAddress [/ip dns cache get $i address] ;
:put $tmpAddress;
:if ( [/ip firewall address-list find ] = "facebook" ) do={
/ip firewall address-list add address=$tmpAddress list=facebook_dns_ips comment=$cacheName;
} else={
:foreach j in=[/ip firewall address-list find ] do={
:if ( [/ip firewall address-list get $j address] = $tmpAddress ) do={
#:set bNew false;
}
}
:if ( $bNew = true ) do={
/ip firewall address-list add address=$tmpAddress list=facebook_dns_ips comment=$cacheName;
}
}
}
}

Enjoy!

Info Paolo Daniele

Ingegnere delle Telecomunicazioni, appassionato di informatica fin da piccolo ho trasformato la passione in lavoro. Con il PHP faccio tutto (o quasi...) ma non disprezzo altri linguaggi all'occorrenza. Se vi piace il mio sito, o vi è utile, o vi sto simpatico, offritemi una birra!

Ti potrebbe interessare

Mikrotik VLAN Hybrid

Ciao Ragazzi, oggi parliamo della gestione delle VLAN su Mikrotik con una versione di routerOS …

Un Commento

  1. Ahmad khoshnaw

    thank you .. lavoro greate

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *